Unable to detect data center for the server name XXX.database.windows.net

Aug 29, 2012 at 3:51 PM

Hey

I'm trying to export my azure database but I have the folowwing message:

"Unable to detect data center for the server name XXX.database.windows.net"

Here is my commandline:

DacIESvcCli -S XXX.database.windows.net  -U myUserName -P myPassword -D myDBName -MX -BLOBACCESSKEY myBlobAccessKey -BLOBURL https://xxx.blob.core.windows.net/databases/test.bacpac -ACCESSKEYTYPE storage.

 

Thanks to help!

Aug 30, 2012 at 6:34 PM

Is your server in the Blu or Bay datacenters?  If so then you need to download the latest version of the tool (v1.6) here.  Be sure to unblock the zip file before extracting.  Also make sure you have two files in the same folder after unzipping:  DacIESvcCli.exe.config & DacIESvcCli.exe

http://sqldacexamples.codeplex.com/releases

Oct 11, 2012 at 11:06 AM

Hi,

I am getting the same error. I do have the latest version of the DacIESvcCli  files. both exe and the config. I have also unblocked both the files.

Any pointers would be appreciated.

TIA!!!!!!

Nov 12, 2012 at 10:50 PM

@TheSeeker - daciesvccli is being deprecated.  We recommend that folks write their own client application.

Regarding this message, are you certain your servername is spelled correctly?  If you ping servername.database.windows.net do you see a response like the following?  The prefix (in this case sn1) indicates the datacenter associated with the server.  Your DACIESvcCli.exe.config should have a corresponding endpoint defined for that datacenter.

Pinging data.sn1-1.database.windows.net [65.55.74.144] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 65.55.74.144:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),