Getting the status of a request not working.

Oct 1, 2012 at 6:38 PM
Edited Oct 1, 2012 at 6:41 PM

Pretty sure this command is not working:

DacIESvcCli.exe -s server.database.windows.net -u MyAdminLogin -p MyPassword -requestid myRequestID -status

I tried using this too:

DacIESvcCli.exe -status -s server.database.windows.net -u MyAdminLogin -p MyPassword -requestid myRequestID 

Based on the notion from a previous post that order is required...  I am assuming myRequestID

is the guid that is returned to you from when you request an export.  

 

Both of these commands currently list all requests for that server.  Also when it lists all commands for the server it doesn't include the ids of the requests in the output.  Which would be useful if the other command doesn't work.

Oct 2, 2012 at 6:11 PM

The -status seems to work, but the -requestid part does not.... this is troubling because the -status return does not include the requestId

 

Oct 2, 2012 at 10:54 PM
Edited Dec 8, 2012 at 12:32 AM

This is a known issue. 

The Status REST endpoint correctly returns the entire result including the request id however daciesvccli does not display the request id.  In addition, daciesvccli ignores the request id and always returns all requests for a server.

Instead we recommend that you write your own program to call the REST endpoints directly.

Code samples for using the Import/Export REST API - http://code.msdn.microsoft.com/windowsazure/Windows-Azure-SQL-Database-5eb17fe2#content