10020: This DACPAC was created using a newer version of DAC Framework

Dec 16, 2011 at 3:32 PM

Hi,

I get this error using DacClient 1.2 with Data tier 2012 RC0

I created my bacpac on november the 15th.

Any clue ?

Dec 16, 2011 at 3:39 PM

My bad, I did not install all the newer versions of the prerequisites.

Jan 5, 2012 at 3:55 PM

Hi,

did you have more information?

I have the same issue.

but I didn't find a list of prerequistes, and a link to download them.

thanks for your help

Jan 5, 2012 at 4:00 PM

Hi,

The prerequisites are available here : http://sqldacexamples.codeplex.com/wikipage?title=Required%20Assemblies%20Links&referringTitle=Home

Jan 5, 2012 at 4:14 PM

thanks

everything is allready up to date; but still not working. I have to check the option to create the dacpac file for the previous version of the framework. but the new one doesn't works.

 

Coordinator
Jan 25, 2012 at 6:49 PM

willgart,

can you provide more details around what you used to generate the bacpac file and how you are attempting to use it?

Example:  exported from SQL Server 2008r2 using SQL Server 2012 RC0 DAC binaries, now attempting to import to SQL xxxx with DAC binaries version xxxx.